Linux Mint en Asus Eee PC 1215B

Para inaugurar mi cuaderno de bitácoras voy a comentar los dos problemas que he tenido al instalar Linux Mint 11 LXDE en el netbook Asus Eee PC 1215B.

Los problemas que he tenido, aparte de tener que crear el USB porque no tiene lector de CD, han sido principalmente el audio y una marca de agua por parte de los drivers propietarios de ATI.

Audio
En el caso del sonido parece que sí que estaban instalados los drivers, pero por alguna razón no usaba el dispositivo correcto y por lo tanto no se oía nada. Para arreglarlo, he seguido los pasos que encontré en este hilo, que son los que paso a enumerar.

Primero, averiguar el identificador de tu tarjeta de sonido.
cat /proc/asound/card0/id
SB

cat /proc/asound/card1/id
SB_1

Estos dos son los identificadores con los que hay que probar. En el hilo del foro dice que modificó el fichero /etc/modprobe.conf. Hay que tener en cuenta que el foro consultado es de archlinux y puede ser que en esa distro esté activo dicho fichero. En Mint, lo comprobé y no existía y además mirando el manual ( man modprobe.conf ) pone que se tiene en cuenta pero que es posible que en un futuro no. Así pues, usé el fichero de configuración del sonido /etc/modprobe.d/alsa-base.conf añadiendo al final la linea que pone en el foro:

options snd-hda-intel id=SB_1 index=1

Como se puede ver usé el identificador SB_1 directamente, ya que es el que ponía que funcionaba. Si no hubiese funcionado, simplemente habría que haber probado con el otro. Después de modificar el fichero reinicié y ya funcionaba el audio.

Video

En el caso del video la cosa es distinta. Al iniciarse por primera vez Mint, ya te detecta la gráfica y te sugiere la instalación del driver propietario, o privativo que diría RMS :)
El driver se descarga y se instala solito una vez le das a activar. El problema es que, una vez reiniciado, sale una marca de agua en la esquina inferior derecha que dice "AMD Unsupported Hardware", lo cual no es cierto porque va bien, con la resolución de pantalla correcta y todo.

El problema es con el fichero de control, que o no está o tiene algún problema. ¿La solución? Bajarse de ATI los drivers en un ejecutable .run, descomprimirlo y coger el fichero en concreto y sobreescribir el incorrecto.

Para descomprimirlo hay que, primero, darle permisos de ejecución y segundo, ejecutarlo con la opción --extract y finalmente entrar en el directorio creado.
chmod +x amd-driver-installer-12-1-x86.x86_64.run
./amd-driver-installer-12-1-x86.x86_64.run --extract
cd fglrx-install.BV4ioC/

Después hacemos una copia ( for if the flies... ) del antiguo fichero de control, sobreescribimos y una vez hayamos reiniciado tendría que haber desaparecido el molesto mensajito.
sudo cp /etc/ati/control /etc/ati/control.old
sudo cp common/etc/ati/control /etc/ati/control

Fuente (Audio): Archlinux forum
Fuente (Video): Superuser

Bienvenidos, Benvinguts, Bienvenue, Welcome, Willkommen, ...

Pues eso, bienvenidos a mi humilde blog. :)

En él hablaré de temas informáticos principalmente. Soy ingeniero técnico en informática de gestión y tengo tres años de experiencia como programador. Los temas que trataré en principio serán de programación en android, en la cual me estoy iniciando así como en programación web y en gestión de drupal que es el cms que estoy usando para el blog. Como todo esto es muy aburrido también aprovecharé para quejarme ( es mi vicio :P ) y para poner alguna frikada que me haga gracia.

Además también me gustan mucho los temas científicos por lo que si hay alguna noticia relevante, y me entero, la comentaré aquí. Y ya para acabar iré haciendo recomendaciones de webs que me gusten haciendo un pequeño resumen de lo que se puede encontrar ahí.

El blog está recien instalado por lo que irá cambiando su aspecto hasta que encuentre uno que me agrade. Si queréis saber algo más de mi, podéis echarle un ojo a la sección acerca de.

Un saludo, Juan.

Suscribirse a El blog de Juan Aguilera RSS